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EasyNN-plus help 

 
 

EasyNN-plus grows multi-layer neural networks from the data in a Grid.  The neural network input and 
output layers are created to match the grid input and output columns.  Hidden layers connecting to the 
input and output layers can then be grown to hold the optimum number of nodes.  Each node contains a 
neuron and its connection addresses.  The whole process is automatic.  
 
The grid is produced by importing data from spreadsheet files, tab separated plain text files, comma 
separated files, bitmap files or binary files.  The grid can also be produced manually using the 
EasyNN-plus editing facilities.  Numeric, text, image or combinations of the data types in the grid can be 
used to grow the neural networks.   
 
The neural networks learn the training data in the grid and they can use the validating data in the grid to 
self validate at the same time.  When training finishes the neural networks can be tested using the 
querying data in the grid,  using the interactive query facilities or using querying data in separate files.  
 
The steps that are required to produce neural networks are automated in EasyNN-plus. 
 
EasyNN-plus produces the simplest neural network that will learn the training data.  The graphical editor 
can be used to produce complex networks. 
 
The EasyNN-plus facilities are shown in this manual.  
 
The first part of this manual covers getting started, samples and projects.  Experienced users can skip 
those sections.  
 

EasyNN-plus help 

 Getting Started 
 Data to Neural Network 
 Grid data Formats 
 Starting with Images 
 Inside EasyNN-plus 
 Samples 
 Projects 
 Shortcuts 
 Cloning Hidden Nodes 
 Learning Threads 
 Main Window's elements 
 Toolbars 
 Main Dialogs 
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Getting Started 

If you prefer an interactive guide click the Getting Started button on the EasyNN-plus Tip 
of the Day dialog. 
 
This exercise is a step by step guide that results in a neural network that is trained to produce the 
secondary color from pairs of the three primary colors.  The primary light colors are used (red, green and 
blue) rather than primary pigment colors (red, yellow and blue).  The guide is mainly about using the 
keyboard to navigate and enter data in the Grid however it is possible to navigate using the mouse if you 
prefer.  The first few steps are described in detail.  The process gets easier as you complete each stage. 
 
Press the New toolbar button or use the File > New menu command to produce a new neural network 
Grid. 
 
An empty Grid with a vertical line, a horizontal line and an underline marker will appear.  The marker 
shows the position where a column and row will be produced. 
 
Press the enter key and you will be asked "Create new Example row?" - answer Yes. 
You will then be asked "Create new Input/Output column?" - answer Yes. 
You have now created a training example with one input.  The example has no name and no value. 
The example will be labeled "T:0" for training row 0.  The input/output column will be labeled "I:0" for 
input column 0. 
 
Press the enter key again and you will open the Edit Grid dialog.  This dialog is used to enter or edit all 
of the information in the Grid. 
Enter "1" in the Value edit box and then tab.   
Enter "Pair 1" in the Example row edit box and then tab. 
The Type is already set to Training so just tab again. 
Enter "Red" in the Input/Output column edit box and then press OK. 
You now have an example named "Pair 1" with an input named "Red" with the value set to 1.0000 
 
Press the right arrow key and then press enter. 
You will be asked "Create new Input/Output column?" - answer Yes. 
 
Press enter and you will open the Edit Grid dialog again. 
Enter "1" in the Value edit box and then tab three times. 
Enter "Green" in the Input/Output column edit box and then press OK. 
 
Press the right arrow key and then press enter. 
You will be asked "Create new Input/Output column?" - answer Yes. 
 
Press enter and you will open the Edit Grid dialog again. 
Enter "0" in the Value edit box and then tab three times. 
Enter "Blue" in the Input/Output column edit box and then press OK. 
 
Press the right arrow key and then press enter. 
You will be asked "Create new Input/Output column?" - answer Yes. 
 
Press enter and you will open the Edit Grid dialog again. 
Enter "1" in the Value edit box and then tab three times. 
Enter "Yellow" in the Input/Output column edit box. 
Click the Output and the Bool radio buttons and then press OK. 
 
Press the right arrow key and then press enter. 
You will be asked "Create new Input/Output column?" - answer Yes. 
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Press enter and you will open the Edit Grid dialog again. 
Enter "0" in the Value edit box and then tab three times. 
Enter "Cyan" in the Input/Output column edit box. 
Click the Output and the Bool radio buttons and then press OK. 
 
Press the right arrow key and then press enter. 
You will be asked "Create new Input/Output column?" - answer Yes. 
 
Press enter and you will open the Edit Grid dialog again. 
Enter "0" in the Value edit box and then tab three times. 
Enter "Magenta" in the Input/Output column edit box. 
Click the Output and the Bool radio buttons and then press OK. 
The first training example "Pair 1" is now complete along with all the inputs and outputs. 
Two more training examples need to be created called "Pair 2" and "Pair 3".   
Use the arrow keys to move to the Grid location below the 1.0000 in the "Red" column. 
 
Press the enter key and you will be asked "Create new Example row?" - answer Yes. 
 
Press enter again and you will open the Edit Grid dialog. 
In the Input/Output column the name "Red" and the type Input are already in the Edit Grid dialog.   
Enter the value "0" and example row name "Pair 2" then press OK. 
Move to each Input/Output column in turn and press the enter key. 
Enter the following values followed by OK. 
Input column "Green" enter the value "1" 
Input column "Blue" enter the value "1" 
Output column "Yellow" enter the value "0" 
Output column "Cyan" enter the value "1" 
Output column "Magenta" enter the value "0" 
 
Repeat the process again for "Pair 3" but this time use the following values. 
Input column "Red" enter the value "1" 
Input column "Green" enter the value "0" 
Input column "Blue" enter the value "1" 
Output column "Yellow" enter the value "0" 
Output column "Cyan" enter the value "0" 
Output column "Magenta" enter the value "1" 
 
You now have all the data that is required to create and train the neural network. 
 
Press the save toolbar button or use the File > Save menu command to save the Grid before continuing.  
Call it "Network".  The name could be anything but this exercise assumes it will be "Network". 
 
To create the neural network press the Grow new network toolbar button or use the Action > New 
Network menu command.  If the toolbar button is not enabled make sure that you have set the first three 
Input/Output columns to Input and the last three Input/Output columns to Output. 
 
This will open the "New Network" dialog. 
Check Grow layer number 1 and press OK. 
If you get a "Generating new network will reset learning." warning message answer Yes. 
The neural network will be produced from the data you entered into the Grid.   
 
Answer Yes to the message "Do you want to set the controls?". 
 
Check Optimize for both Learning Rate and Momentum and then press OK. 
Answer Yes if you get the "Optimizing controls will reset learning." warning message. 
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The controls will be set and the neural network will be ready to learn. 
 
Answer Yes to the message "Do you want Network.tvq to start learning?". 
 
Press the View network toolbar button or use the View > Network menu command to see the new neural 
network. 
 
Press the View learning graph toolbar button or use the View > Graph > Learning Progress menu 
command to see how the error reduced to the target level. 
 
Press the Query network toolbar button or use the Query > Query menu command to open the Query 
dialog. 
 
Press the Add Query button and then answer OK to the Example Presets dialog.  An example named 
"Query" with unknown values will be generated and selected. 
 
Select a name or value from the Input lists and press the Max button.  Select another name or value 
from the Input lists and press the Max button.  Select the last name or value from the Input lists and 
press the Min button. 
Notice that the correct secondary color in the Output Names list is set to "true". 
Select a name from the Output lists and press the Seek High button and then the Start/Stop Cycle 
button.  The seek cycle will stop automatically. 
Notice that the correct pair of primary colors have the values set to 1.0000 in the Inputs list. 
Press the Close button. 
 
Press the View grid toolbar button or use use the View > Grid menu command to return to the Grid view. 
 
Notice that the example named "Query" has been added to the Grid.  This example can be edited using 
the same Edit dialog you used to produce the Training examples.  The Grid will be updated to show the 
edited values and the results.   
 
Set any pair of primary colors to 1 and notice that the corresponding secondary color is set to "true". 
 
You have now used all the basic functions in EasyNN-plus. 
 
You should have no difficulty converting the neural network to produce secondary pigment colors from the 
primary pigments.  You could then try to modify the pigments network to produce a "Black" output when 
all three primary pigment inputs are present and a "White" output when all three are absent. 
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Data to Neural Network 

This procedure is a step by step guide to creating a neural network from a data file. 
 
All you need to start is the Races.txt file.  You will find a copy in the samples folder. 
Have a look at the contents of the file.  You will see that the column titles are on the first line and the 
other lines start with the line number in square brackets  We will use the titles for column names and the 
numbers for row names.  Some of the values in the race data are integers and some are boolean. 
 
The file contains data from 370 horse races.  The aim is to create a neural network that can be trained 
and validated using the horse race data. 
 
After the neural network has been trained and validated it can be used to help predict the winner of other 
races. 
 
Press the New toolbar button or use the File > New menu command to produce a blank grid for a new 
neural network. 
 
An empty Grid with a vertical line, a horizontal line and an underline marker will appear. 
 
Now select File > Import... 
 
The file selection dialog will appear.  
 
Open the file Races.txt in the samples folder. 
 
The first Import dialog will appear with the Tab delimiter already checked.   
 
Each line is numbered in Races.txt so that can be used as the row name.  Select "Use first word(s) on 
each line for row names".  Press OK. 
 
The second Import dialog will appear. 
 
Press the Set names button. 
 
The first line and the column names will be set. 
 
The third import dialog called Input/Output Columns will appear.  The settings in this dialog are based 
on the value being imported but they should be checked.  In particular the mode and type may not 
always be correct. 
 
Column 0 will be ready to setup.  The column is called Runners and has a value of 11.  The column 
settings will be correct so press OK. 
 
The next column will now be shown.  This column is Distance with a value of 7.  The settings are 
correct so press OK. 
 
Column 3 is Handicap with a value of 0.  The mode will change to Bool.  Press OK. 
 
Column 4 is Class and is another integer.  The mode will change back to Integer.  Press OK. 
 
Column 5 and 6 are boolean so the mode will be set to Bool.  Press OK for both columns. 
 
The last column is Win and is also a boolean so the mode will be correctly set.  The type is not correct 
and needs to be changed to Output.  Then press OK. 
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The data will be imported and the grid columns will be set to the correct mode and type. 
 
The Grid is now complete. 
 
To create the neural network press the Grow new network toolbar button or use the Action > New 
Network menu command. 
 
This will open the New Network dialog. 
Check Grow layer number 1 and press OK. 
If you get a "Generating new network will reset learning." warning message answer Yes. 
The neural network will be produced from the data you imported into the Grid.   
 
Answer Yes to the message "Do you want to set the controls?". 
 
This will open the Controls dialog. 
Check Optimize for both Learning Rate and Momentum. 
We need to change 100 of the training rows to validating so enter 100 in Select examples at random.   
There is no point in training the neural network for more than 1000 cycles so check Stop on cycle and 
enter 1000. 
Press OK.  Answer Yes if you get the "Optimizing controls will reset learning." warning message. 
 
The controls will be set and the neural network will be ready to learn. 
 
A summary of the control settings and what is going to happen next will appear. 
Answer Yes to the message "Do you want filename to start learning?".  The filename will probably still be 
called untitled.tvq, there is no need to change it unless the file is saved. 
 
The AutoSave dialog will open.  Nothing needs to be done so just press OK. 
 
Learning and validating will run for 1000 cycles.  Use View > Information to see the results.  The line 
Validating results: ... is all that matters.  If everything has worked as expected the neural network will 
have correctly predicted the results of at least 64% of the races. 
 
That is the end of this exercise. 
 
If you want to try using the query facilities to input details of races and horses you can enter the queries 
directly into the Grid or use the Query dialog. 
 
If you are using the full version you will be able to use a File Query to produce a results file for a whole 
days racing.  Races that indicate no winners or multiple winners should be ignored. 
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Grid data Formats 

Grid Data Types and Modes 
 
The Grid in EasyNN-plus  can contain numeric, text, image or combinations of different data formats.  
 
Numeric data can be integer, real or boolean (true or false).   
 
Text strings can be entered or Imported into the Grid.  Text can mixed with numeric data in Example 
rows but not in Input/Output columns.  Columns can be set to text mode using the Edit dialog or while 
Importing. 
 
Each text string in the Grid will have an associated numeric value.  This numeric value is the sum of the 
ASCII code multiplied by its position in the string.  For example, the word 'Dog' is (68 * 3) + (111 * 2) + 
(103 * 1) = 529.  The numeric value of each text string is checked when it is first calculated to make sure 
that it is not too close to another string.  If it is found to be within 100 of any other string then 101 is 
added to the numeric value and it is checked again.  Every text string has a unique associated numeric 
value. 
 
EasyNN-plus neural networks use the associated numeric value for all calculations. 
 
Words and phrases do not have any intermediate text that can be calculated.  For example, 'Cog' is 
alphabetically intermediate to 'Cat' and 'Dog' but it does not have much to do with either animal.  'Dog' 
and 'Cat' will have the associated values of 529 and 713 if they are entered into the same column in that 
order.  The intermediate values will have no associated text.  EasyNN-plus will find the nearest 
associated numerical value for the Output columns of the query rows.  The text is prefixed with a series 
of '~' characters depending on how close it is.  The intermediate value 712 would give the text '~Cat', 700 
would give '~~Cat' and 600 would give the text '~~~Dog'. 
 
The Edit > Replace facility in EasyNN-plus can replace numeric values with text but this should be used 
with caution.  The numeric values associated with the text will not usually have a direct relationship with 
the numeric values that are being replaced.  The series of numbers 1, 2, 3 and 4 could be replaced with 
the text One, Two, Three and Four.  The associated numeric values would be 558, 702, 1481 and 961.  
After scaling the original series would be 0.0000, 0.3333, 0.6667 and 1.0000.  The replaced text would 
be 0.0000, 0.1561, 1.000 and 0.4366 after scaling.  The two series of numbers do not have a simple 
relationship so, in this case, text should not be used to replace a simple numerical series.   
 
Images can be entered or Imported into the Grid.  Any bitmap image can be used in EasyNN-plus.  
Bitmaps of different sizes can be mixed.  Other image formats (jpeg, gif etc) must be first converted to 
bitmap format.  Images can be mixed with text and numeric data in Example rows but not in Input/Output 
columns.  Columns can be set to image mode using the Edit dialog or while importing.   
 
Each image in the Grid will have a name, a bitmap file and three associated numeric values.  These 
numeric values are the Pixel Pair Code (PC), the Edge Code (EC) and the Block Code (BC).  PC is 
derived by comparing a thousand pairs of pixels in the image.  The positions of the top, bottom, left and 
right outer edges are used to produce EC.  The position of the largest block of pixels with the same color 
is used to produce BC. EasyNN-plus must have access to the bitmap file to produce PC, EC and BC.  
Large bitmaps will take a few seconds to process.  If EasyNN-plus cannot find the bitmap file a selection 
dialog will be opened so that the file can be located.  This selection dialog is also used while a file is 
being imported whenever a bitmap file is needed.  Once the images are in the Grid they can be used to 
produce networks in the same way as any other type of data.  Every image Input and Output column in 
the Grid will map onto three nodes, a PC node, a EC node and a BC node. 
 
Images can be fragmented into component parts using Edit > Fragment Image.  Images and fragments 
can be associated with the values in other Input/Output columns using Edit > Associate Image.   
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Starting with Images 

Multiple images can be included in the Grid.   

 
Images will be encoded into three separate nodes when the neural network is created.  Images can also 

be fragmented into parts in the Grid.  Each part will be encoded separately. 

 
This procedure is a step by step guide that produces a neural network using an image in the Grid .   

 
For this exercise you will need a bitmap image file in which you can identify a component part.  For 

example, a nose on a picture of a face, a car on a str eet, a tree in a garden, any distinctive object will do.  

The bitmap image will be entered into a new Grid where it will then be broken into fragments.  The 
fragments will appear in a Grid Input column.  An Output column will be created that will be associ ated 

with the fragments.  The values in the associated column will be set to identify the fragment containing 
the component.  The two columns will then be used to create a neural network.  

 

Some of the steps in this procedure will be the same as those in th e Getting Started  topic but they will 
be repeated here. 

 
Press the New toolbar button or use the File > New  menu command to produce a new neural network,  

 

An empty Grid with a vertical line, a horizontal line and an underline marker will appear.  The marke r 
shows the position where a Grid column and row will be produced.  

 
Press the enter key and you will be asked "Create new Example row?" - answer Yes. 

You will then be asked "Create new Input/Output column?" - answer Yes. 
You have now created a training example with one input.  The example has no name and no value.  

 

Press the enter key again and you will open the Edit Grid dialog. 
Type a word such as "picture" in the Value edit box.  It is just a name to use for the image, it will be 

deleted later. 
Click the Image radio button and press OK. 

 

The Image File  selection dialog will appear.  Enter the location of your bitmap file or use Browse to 
locate it.  Press OK when you have found your image.  

 
The bitmap file will be selected, encoded and inserted into the Grid. 

 
Double click the image in the Grid to open the Image dialog. 

 

Press the Fragment button to open the first Fragment Image dialog.  The bitmap file will already be 
in this dialog so just press OK to open the second dialog. 

 
The entries in the second dialog are already set correctly so just press OK again. 

 

The image will be fragmented into 16 parts and entered into the Grid.  The first fragment will overwrite 
the original image which is no longer needed.  

 
Press the right arro w  key and then press enter . 

You will be asked "Create new Input/Output column?" - answer Yes. 

 
Press enter and you will open the Edit  Grid  dialog again. 



 15 

 

Click the Bool and Output radio buttons and press OK. 

 
All the outputs need to be set to 'false' except  the one that corresponds to the fragment containing the 

component part which is set to 'true'.  It is possible to enter the values directly using the Edit Grid  
dialog but in this exercise we will use an association between the two columns.  This will allo w the 

Output column values to be edited while viewing the Input column fragments.   

 
Press the left arrow  key to move back to the Grid column that contains the fragments.  

 
Select Associate Images...   from the Edit menu to open the Associate Images  dialog. 

Enter 1 in the Input/Output  column edit box and press OK. 
 

The Image Fragment  dialog can be opened either by double clicking the image fragment in the Grid or 

moving to the fragment and pressing enter . 
Open the dialog for each fragment in turn.  If the fra gment contains the component part that you have 

chosen to identify then enter 't' in the associated value edit box.  If the fragment does not contain the 
component part enter 'f'.  

 

Use the Action > New Network  menu command to open the New Network  dialog. 
Check Grow layer number 1  and press OK. 

If you get a "Generating new network will reset learning." warning message answer Yes. 
 

Answer Yes to the message "Do you want to set the controls?".  
 

Check Optimize for both Learning Rate  and Momentum and then press OK. 

Answer Yes if you get the "Optimizing controls will reset learning." warning message.  
The controls will be set and the neural network will be ready to learn the image fragments and 

associations that you have entered into the Grid. 
 

Answer Yes to the message "Do you want it to start learning?".  

 
The learning process should run to completion and stop automatically but it can be stopped by pressing 

the Stop toolbar button or using the Action > Stop  menu command.  If the learning process does not 
stop automatically then it is probably because the basic neural network that has been created cannot 

uniquely classify the fragment with your chosen component.  The purpose of this exercise was only to 

introduce the use of images and fragments in the Grid a nd you have now used all the facilities.  
However, if you want to continue and make the neural network classify the component try using more 

hidden nodes.  If that does not help, try two hidden layers.  If it still does not work it may be that the 
component fragment you have chosen produces a similar value to other fragments when they are 

encoded.   
 

Press the Query toolbar button or use the Query > Query  menu command to open the Query dialog. 

 
Press the Add Query  button.  Press OK in the Querying presets  dialog.  An example named "Query" 

will be generated and selected.   
 

Select the Output and Start/Stop Cycle  for a few seconds to check if the correct fragment is identified 

in the Inputs .  The Output may be incorrect.  It is usually possible to produce the correct Output by 
setting the Target Error  to a lower value in the Controls dialog and then continuing Learning.   

 
This method has been used successfully to identify the presence of cars on photographs of streets.  The 

images were fragmented and then the associated bool value was set to true for each fragment that 
contained a whole side view of a car.  After the network correctly identified the cars on three streets it 
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could then identify similar car profiles on a number of other street photographs.   
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Inside EasyNN-plus 

A Neural Network produced by EasyNN-plus has two component parts.   
 
The component parts are the Node and the Connection.  These components are replicated to make the 
neural network.  A Node consists of a Neuron with positioning and connecting information. A 
Connection consists of a Weight with node addressing information. 
 
The Grid used by EasyNN-plus also has two components.  These are the Example row and the 
Input/Output column.  These are replicated to make the grid.  
 
 
All the component parts of EasyNN-plus are implemented as reusable classes to simplify future 
development.  The following information is a very basic description of the classes. The true names of the 
variables and functions are not used. 
 
 
The Neural Network 
 
Node 
 
Positioning and connection 
 
Type: 
Input, Output or Hidden. 
 
Number: 
Node reference number. 
 
Layer Type: 
Input, Output or Hidden. 
 
First In: 
Number of the first connection into this node. 
 
Last In: 
Number of the last connection into this node. 
 
Neuron 
 
Net Input: 
Sum of all activation * weight inputs to the node + Bias. 
 
Activation: 
1.0 / (1.0 + e (-Net Input)) 
 
Output Node Error: 
Target - Activation 
 
Hidden Node Error: 
Error + Delta * Weight 
 
Delta: 
Error * Activation * (1.0 - Activation) 
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Bias: 
Bias + Delta Bias 
 
Bias Derivative: 
Bias derivative + Delta 
 
Delta Bias: 
Learning Rate * Bias Derivative + Momentum * Delta Bias 
 
Connection 
 
Node addressing 
 
To: 
The Node that the connection is going to. 
 
From: 
Node that the connection is coming from. 
 
Number: 
Connection reference number. 
 
Weight 
 
Type: 
Variable or Fixed. 
 
Weight: 
Weight + Delta Weight. 
 
Weight Derivative: 
Weight Derivative + To: Delta * From: Activation. 
 
Delta Weight: 
Learning Rate * Weight Derivative + Momentum * Delta Weight. 
 
The Grid 
 
Example row 
 
Name: 
Optional Example name. 
 
Type: 
Training, Validating, Querying or Exclude. 
 
Values: 
Array of values in example row. 
 
Scaled Values: 
Array of scaled values in example row. 
 
Forecasted Values: 
Array of forecasted values in example row. 
 
Input/Output column 
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Name: 
Optional Input/Output name. 
 
Type: 
Input, Output, Serial or Exclude. 
 
Mode: 
Real, Integer, Bool, Text or Image. 
 
Lock: 
True or False. 
 
Lowest: 
Lowest value in column. 
 
Highest: 
Highest value in column. 
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Samples 

Samples included in the samples folder. 
 
Add.tvq  
This network is trained to add two numbers together.  The network has been built with three hidden 
nodes.  The extreme values are duplicated as validating examples in order to terminate the learning 
process as soon as they are correct.  To use this method the Controls need to be adjusted so that Stop 
when 100.00% of the validating examples are Correct after rounding is set. 
 
Basket.tvq 
This sample is to demonstrate the Associating facility.  The examples are taken from discarded till 
receipts at a small general groceries and provisions store.  Pairs and clusters of associated items in the 
shopping baskets can be found using Action > Start Associating.  In this sample the associations can 
indicate shopping habits.  Most of the important item pairs are close to each other in the store indicating 
the importance of layout on which items finish up in the shopping basket.  The various types of soup 
show this association quite clearly.  Some important item pairs are not close together in the store but will 
be used together later such as Milk and Custard Powder.  A few of the associations are difficult to 
explain. 
 
Cichlids.tvq  
Some East African Cichlid fishes are difficult to classify because many of the characteristics that are 
normally measured for classification purposes lie in overlapping ranges.  The network has been trained 
using the published descriptions of 16 different, but closely related, cichlids.  Ten characteristics have 
been measured in each case.  In this sample only one example has been used for each species.  
Periodic validating with the same data is used to terminate the learning process as soon as 100% correct 
classification is reached.  It is more usual to use different validating and training data.  After the network 
has been trained to be 100% correct on the training examples it can be used to identify other specimens.   
 
If any cichlid experts are using EasyNN-plus the characteristics measured are SL - standard length, BD - 
body depth, HL - head length, PD - preorbital depth, CP - caudal length, UJL - upper jaw length, LJL - 
lower jaw length, LL - lateral line scales, D spines - dorsal spiny rays, D branched - dorsal branched rays.  
The descriptions used are taken from 'A revision of the Haplochromis and related species (Pisces : 
Cichlidae) from Lake George, Uganda' by P.H.  Greenwood 1973.  The Haplochromis and related 
genera have been revised since and the names used in this example have probably now been changed. 
 
Diggers.tvq 
This is a simple planning example.  It shows how a neural network can be used to estimate the digging 
rate of one to four diggers under a variety of conditions.  The output of the network is the number of 
kilograms per hour dug from a hole.  The inputs produce a number of conflicts.  Diggers work best when 
they have a spade to dig with so four diggers with one spade only perform a little better than one digger 
with one spade.  Rocky soil is more difficult to dig but rocks weigh more than soil and we are interested 
in the weight rather than the volume.  The amount of clay also has some impact on the digging rate but it 
also weighs more than soil - but not as much as rocks.  Cold soil is difficult to dig.  Frozen soil is very 
difficult to dig.  On the other hand, diggers need more rest breaks when the temperature is high.  If the 
diameter of the hole is too small then the number of diggers who can work down the hole is limited.  
However the diggers who are not digging must be resting so high temperature is less of a problem. 
 
Discounts.tvq 
This network is trained using a number of fixed discount breakpoints so that intermediate discount prices 
can be estimated.   
 
Grocer.tvq 
This demonstrates the use of the Seek buttons.  A retail grocer adjusts his prices according to the 
wholesale prices every morning when he collects his stock for the day.  He always tries to make a 
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reasonable profit but he knows from experience that to maximize his profit he cannot just increase his 
prices.  When his prices reach a certain level his profit starts to decrease because his item sales begin to 
decrease.  The neural network has learned the relationships between some prices and the resulting daily 
turnover and profit.  Using Seek High the grocer can see which price combinations produce the 
maximum profit or maximum turnover.     
 
Hometime.tvq 
This network has been trained using journey times and the routes from work to home.  It is a short 
journey through a very busy area with variable traffic.  The object is to find the fastest route home at a 
given time.  The departure and arrival times are in decimal hours, not hours and minutes.  The journey 
has five common points including the start and end.  It uses the names of the roads to indicate the route 
taken on each stage of the journey between adjacent common points.  The example journeys cover a 
period of one year so the most recent traffic and road conditions influence the neural network.  To find 
the fastest route home using Query the departure time (in decimal hours) is Set in the input list and 
locked by clicking its Lock in the list.  Then the Seek Low facility can be used to find the earliest arrival 
time and thus the fastest route home for that departure time. 
 
House prices.tvq 
This is a simple example showing how EasyNN-plus can be used to estimate house prices.  It has been 
trained using a small number of houses around the Stockport (UK) area.  It uses the information 
commonly found in estate agents advertisements.  A very small subset of items of description has been 
chosen for input along with the location of the house.  The location inputs are postal area codes for 
Stockport (SK1 to SK8).  Some of the training cases are incomplete (indicated by a '?' in the training 
example) and allowed to default.  It produces quite accurate results when tested against agents data for 
houses in a similar area in the same year (1993).   
 
Iris.tvq 
The data in this example is from Fisher, R.A.  "The use of multiple measurements in taxonomic 
problems" Annual Eugenics, 7, Part II, 179-188 (1936), also in "Contributions To Mathematical Statistics" 
(John Wiley, NY, 1950).  The data has been used many times before to demonstrate how neural 
networks (and other techniques) can be used for classification.  50 examples of three species of Iris are 
used to train the neural network.  Two of the sets of data are not linearly separable.  After training the 
network gets 100% correct.   
 
Logic.tvq 
All the two input logical functions are simulated using this neural network. 
 
Parity 3.tvq 
Three bit, odd parity example using validating examples to stop training as soon as 100% correct results 
are achieved. 
 
Parity 4.tvq 
Four bit, odd parity example trained, without using validating examples, until a low error is achieved. 
 
Random data.tvq 
This network uses random data for both training and validating.  It demonstrates that a neural network 
can be trained using random data but shows that no amount of training will produce good validating 
results. 
 
Signature.tvq 
A bitmap image of 42 forged signatures has been split into individual parts using the Fragment facility.  
Each fragment contains one signature and has been associated with a bool in the adjacent Output 
column.  The signatures have been assessed by the potential victim of the forgery to see which are good 
fakes.  That is, which ones would fool him.  Ten Example rows have been chosen at random and set to 
Querying so they will not take part in the training.  These Querying examples are used to test the network 
after training.  The network has then been created starting with 10 hidden nodes and allowed to grow.  It 
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converges quickly when the hidden nodes are incremented to 11.  The excluded column named 
"reference" allows the Querying results to be compared with the original values.  The network gives the 
correct result for 9 of the 10 Querying examples.  It gets fg000002 wrong. 
 
Species.tvq 
In this network one of the input columns and the output column is text data.  It is a simple species 
classification network.  It shows the problem that can occur when text is used in an output column 
because intermediate values cannot be calculated.  The network requires to be trained to a very low 
error before it classifies the species correctly.   
 
XOR.tvq 
The standard "exclusive or" test that most neural networks systems use for demonstration purposes.  
This sample is used in the interactive Getting Started exercises. 
 
See the Projects for more samples. 
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Projects 

Projects included with the Samples: 
 
Simulating a Network with ExcelStuart Moffatt 
 
A Test Excel SimulationMarco Broccoli 
 
Classifying Components from imagesDepartment of Mechanical Engineering,  Loughborough 
University 
 
Predicting Soccer ResultsHarry Molloy 
 
Predicting Horse Race WinnersTom Huxley 
 
Other Projects: 
 
Maximising retail profit. 
This project was based on the "Grocer.tvq" sample that is supplied with EasyNN-plus.  The main 
difference is that the network was trained to identify the "special offers" that resulted in the most shoppers 
visiting the store and the subsequent profit.  It was noted that there was no simple, direct relationship 
between the number of visitors and the profit.   
 
Estimating property prices. 
This is another project that started with one of the samples.  The "House prices.tvq" sample is based on 
house prices around Stockport in England.  It was modified using commercial property prices in an area 
of New York.  Other than being trained with different measures it is the same network as the sample.  
Most of the room counts were replaced with floor space sizes. 
 
Food product grading. 
A producer of "traditional" oat biscuits wanted a method that could determine the best biscuits in batches 
of thousands.  The best biscuits were those that looked to be homemade.  The network used the images 
of freshly baked biscuits.  Three states were determined by manual inspection.  These were "regular", 
"homemade" and "irregular".  The network took over a day to train and validate because the images were 
very complex.  It could then identify biscuits that had the homemade look.  The next stage in the project 
is to incorporate the network into a machine that will sort the biscuits into different grades for different 
markets.  Regular biscuits go into cylindrical packs.  Homemade biscuits go into flat packs and attract a 
higher price.  Irregular biscuits are broken up and used for other products. 
 
Electricity supply load.   
Predicting the load for an electricity supply and generating company.  The project was to find the time, 
day and conditions that resulted in high loads on an electricity supply.  A neural network was trained 
using the load data for the previous six years sampled once every hour.  This period included extremes 
of temperature, humidity, wind speed and sky cover.  The neural network could then accurately predict 
the load for different weather conditions at any time.   
 
Planning journeys. 
Yet another project that started with a supplied sample, "Hometime.tvq".  It is to find the route that a 
salesman should take to arrive at the most convenient time for the client and result in the most sales.  
The sales workload was also planned using a similar technique.  Long journeys that resulted in few sales 
were given low priorities or avoided completely by referring the client to different ordering methods. 
 
Plant growth. 
This network was developed by a student in a horticultural college to find out which factors were most 
important to growth rate of a type of pine tree used in timber production.  The factors involved were 
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mainly related to rainfall and temperature but also included the different techniques used to encourage 
rapid growth. 
 
Horse race winners. 
This project included a neural network for every race meeting where a group of horse, jockey and trainer 
were expected to compete during a season.  The networks were then combined to produce an imaginary 
race meeting in which the winners would be predictable.  Future real meetings were then carefully 
examined to look for similarities with the model meeting.  If a meeting were identified with any of the 
horse, jockey and trainer combinations involved in the race, a bet would be placed on that horse.   
 
Soccer game results. 
The results of Soccer matches are extremely difficult to predict but a neural network can do a little better 
than just guessing.  A neural network was trained using the scores in hundreds of games, the current 
team positions and historical league positions. 
 
Identifying images of cars. 
A neural network was trained to identify cars on a series of photographs of a busy road and validated 
using a different set of photographs.  After the validating results peaked the network was tested using a 
third set of photographs.  All cars that were presented with a side elevation which did not overlap other 
vehicles were identified.   
 
Wound healing treatments. 
A medical physicist developed a network that was trained using the treatment and medical history of 
hundreds of patients to determine which treatments produced the optimum healing time.   
 
R.J.Taylor et al: Using an artificial neural network to predict healing times and risk factors for venous leg 
ulcers 
Journal of Wound Care Vol.1,No.3 2002 
 
Stroke rehabilitation progress. 
This network was developed by a stroke rehabilitation specialist to help find the combination of therapies 
that produced the best results. 
 
Marc van Gestel 
 
Drug interactions. 
The side effects reported by patients involved in a stage of drug testing were used to train a network.  
The reported symptoms and the dosage of all the drugs being taken were used in the training.  The 
trained network could then indicate possible drug interactions that would need further investigation. 
 
Multiple sclerosis symptoms and treatments. 
This project uses a network that establishes which MS symptoms are related to treatments.  The inputs 
to the network are the treatments and the outputs are the symptom scores over the following eight days.  
A second network uses a much longer period.  In both networks, the importance of the treatments is 
determined after training.  Querying is used to investigate if the importance is due to a positive or a 
negative change in symptoms. 
 
Identifying liver cancer. 
The distinction of hepatocellular carcinoma (HCC) from chronic liver disease (CLD) is a significant clinical 
problem.  In this project a network has been used to help identify tumor-specific proteomic features, and 
to estimate the values of the tumor-specific proteomic features in the diagnosis of HCC. 
 
Poon et al.: Comprehensive Proteomic Profiling and HCC Detection 
Clinical Chemistry 49, No.  5, 2003 
 
Who wrote this? 
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A neural network was trained with hundreds of lines of text extracted from ten novels.  The words per 
sentence, average syllables per word, average letters per word and the actual text were used for inputs.  
The ten authors were the outputs.  After training the neural network could identify the most likely author 
of any given text.  The long term aim of the project is to classify fictional writing styles.   
 
Germination rate. 
Fifty seed trays were used in which 25 seeds of a common food grain were planted.  The germination 
rate was measured and used as the output of a neural network.  The inputs were the drill depth, spacing, 
soil temperature, surface temperature and soil moisture by conductivity.   
 
Chemical analysis. 
An application in gas chromatography which predicts retention indices (the position when a chemical 
compound appears in a chromatogram/plot compared to other components) on the base of topological 
descriptors, which describe the structure and/or properties of a chemical. 
 
Chronic Nephropathies. 
Dimitrov BD, Ruggenenti P, Stefanov R, Perna A, Remuzzi G.  Chronic Nephropathies: 
 
Individual Risk for Progression to End-Stage Renal Failure as Predicted by an Integrated 
Probabilistic Model.  Nephron Clin Pract 2003;95:c47-c59. 
 
Reproductive intentions. 
Stefanov R.  Reproductive intentions of the newlywed Bulgarian families - 
 
artificial neural network approach.   
Folia Med (Plovdiv) 2002;44(4):28-34 
 
 
 
 

 Projects 

 Simulating a Network with Excel 
 A Test Excel Simulation 
 Classifying Components from images 
 Predicting Soccer Results 
 Predicting Horse Race Winners 
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Simulating a Network with Excel 

Some people have created spreadsheets using the connection weights and node biases from the special 
text files that EasyNN-plus can produce.  Some of these spreadsheets are very complex but this method 
is elegantly simple.  The spreadsheet has been adapted to work with the Add.tvq sample.  The Excel 
spreadsheet file, Add.xls, is included with the samples. 
 
by Stuart Moffatt 
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A Test Excel Simulation 

This spreadsheet uses a similar method to the above but it is arranged it in a way to be visually similar to 
the network that it is simulating.  The Excel spreadsheet and EasyNN-plus network file, Test1.xls and 
Test1.tvq, are included with the samples. 
 
by Marco Broccoli 
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Classifying Components from images 

This network demonstrates how a neural network can be used to classify component parts.  The parts 
used are Long Bolts, Short Bolts, Nuts, Circlips and Washers.  The component images are 
preprocessed to produce three inputs for the neural network.  The three inputs are Area, Perimeter and 
Roundness.  Each component part has a bool output column.   
 
The PowerPoint presentation slides, NNDemo.ppt file is included with the samples. 
 
See the Components.tvq sample. 
 
by Department of Mechanical Engineering, Loughborough University 
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Predicting Soccer Results 

Neural networks are often used in the prediction of soccer results.  The methods used are many and 
varied but they usually depend directly on previous scores to assess the team strengths.  The models 

produced often do just a little better than a random cho ice.  The prediction of home and away wins 
using a neural network has proved easier than draw prediction but the soccer expert, almost always, 

does better than a neural network.  Harry uses the ratings that are produced by an expert.  

 
Harry has constructed a neural network that uses some of the RATEFORM values from 

http://members.aol.com/soccerslot/socrates.html  
 

The RATEFORM home  away values and the difference between them are used as inputs.  The match 

result is used for output.  The original network uses three different columns for home, draw and away.  
This can produce misleading validating results because the network has no knowledge that the three 

outputs are exclusive.  So far as the network knows the three outputs have eight different possible 
combinations - not three.  A forth output has been added with three values: 1 - home win, 2 - draw and 

3 away win.  The three original output columns are excluded.  The network produces 53% correct  
results on the validating examples.  A random choice would be only 33% correct.   

 

This shows that Harry's network produces a significant advantage when picking matches.   
 

See the formrates.tvq  sample. 
 

by Harry Molloy 
 

http://members.aol.com/soccerslot/socrates.html
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Predicting Horse Race Winners 

Many horse racing systems are built around the fact that over 60% of winners come from the first two 
horses in the betting.  First2 is an attempt to improve the punters chances of winning, by selecting those 
races that are likely to have a winner coming from the first two in the betting, using a trained Neural 
Network. 
 
Inputs:  
 
Runners (number of runners) 
 
Distance (in furlongs) 
 
Handicap (race type) 
 
Class (1 for A or listed, 2 for B, 3 for C..) 
 
Stake>5k (Prize money for winner is greater than £5000) 
 
Odds>2 (Odds of first horse in the betting is greater than 2/1) 
 
Output: 
 
Win (Is one of the first two in the betting likely to win?)  
 
The data for this network are for flat races run in 1998.   
 
The network is produced with Grow hidden layer 1 checked.   
 
The controls have Optimize and Decay set for both Learning Rate and Momentum.  The Target error 
is set to 0.  The Correct after rounding validating stop is set and 100 examples have been selected at 
random for validating.   
 
Auto Save as been set the save every 100 cycles if the number of correct validating examples have 
increased. 
 
The First.vi.tvq will be produced by AutoSave.  This file can be used to predict the winners.  In the 100 
validating examples it correctly predicts if one of the first two horses in the betting will win in 69% of the 
races.  This is a 9% advantage over the known results.  Is that a big enough advantage to make a profit 
? 
 
See the First2.tvq sample.   
 
by Tom Huxley 
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Shortcuts 

Shortcuts 
 
 
Ctrl  J Jog 
Ctrl  Enter Refresh 
Shift  Space Start learning 
Ctrl  Space Stop 
Ctrl Alt  D Dump  
Ctrl  C Copy 
Ctrl  Insert Copy 
Shift  Delete Cut 
Ctrl  X Cut 
  Delete Delete 
Ctrl  F Find 
Ctrl  A Find again 
  F3 Find again 
Ctrl  G Goto 
Ctrl  T Goto again 
  F4 Goto again 
Ctrl  U Goto used 
Ctrl  F2 Goto used 
Ctrl  V Paste 
Shift  Insert Paste 
Ctrl  H Replace values 
Ctrl  N File new 
Ctrl  O File open 
Ctrl  P File print 
Ctrl  S File save 
  F1 Help 
Ctrl  F4 Play macro 
Ctrl  F2 Record macro 
Ctrl  F3 Stop macro 
  F6 Next pane 
Shift  F6 Previous pane 
Ctrl  F5 Register 
Ctrl  Q Decrease noise 
Ctrl  W Increase noise 
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Cloning Hidden Nodes 

Cloning Hidden Nodes 
 
Cloning can help when there are problems finding a neural network configuration that will learn a 
complex dataset. Neural networks can be built with cloning enabled or cloning can be enabled while the 
network is learning. Hidden nodes are cloned during the learning process when the average error has 
stopped reducing. The hidden node with the greatest net input is frozen to determine if it is contributing to 
the learning process. If the node is contributing to the learning process it is cloned. Nodes that are not 
contributing are skipped and the node with the next greatest net input is tested. If no suitable node can be 
found a new node is created and fully connected with random low weights. It is then cloned producing an 
exact copy. The node that has been cloned is frozen again and its clone takes over in the learning 
process. The freeze level of the node that has been cloned is reduced until both the node and its clone 
are being used in the learning process. The learning process does not need to restart when a node is 
cloned.  
 
About Clones & Cloning 
 
1.Nodes will not be cloned if the neural network is learning and the average error is decreasing.  
 
2.Clones may be produced during learning if cloning is enabled and the average error is not decreasing. 
 
3.Nodes that are cloned are initially frozen. 
 
4.The freeze level may reduce to zero very quickly and never be seen on the network display.  
 
5.Clones are first produced in hidden layer 1, then in hidden layer 2 and then in hidden layer 3. 
 
6.Clones produced in one hidden layer may move to other hidden layers. 
 
7.Networks that have been created with no hidden nodes or connections can use cloning.   
 
8.Clones can be cloned.  
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Learning Threads 

EasyNN-plus neural networks can be trained using more than one learning thread.  Some networks will 
learn much faster with multiple threads but there is no simple relationship between the learning speed 
and the number of threads.  The optimum number of threads can only be found by experiment.   
 
Up to eight learning threads can be started using the threading control in the Controls dialog.   
 
All EasyNN-plus threads run at a low priority so that other applications and the operating system do not 
slow down while the learning threads are running.   
 
To avoid stopping too early or over shooting the target error the number of learning threads is reduced to 
one as the target is approached.   
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Main Window's elements 

The main windows are selected with a single click on the view Toolbar button. 

 

 

 Main Window's elements 

 EasyNN-plus main window 
 Grid 
 Network 
 Learning Progress 
 Predictions 
 Associations 
 Column Values 
 Example Errors 
 Input Importance 
 Sensitivity 
 Macros & Scripts 
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EasyNN-plus main window 

  

 

The main EasyNN-plus application window. There are nine views and six toolbars. The views and 
toolbars can be selected, moved to any position, switched on and off as required. The grid view is 
selected with all the toolbars switched on. 
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Grid 

  

 

The Grid  view shows all the Examples arranged in rows and all the Input/Outputs arranged in columns.  

The first column contains the Example types and names.  The first row contains the Input/Output types 
and names.  Everything on the Grid can be edited by moving t o the cell containing the value and then 

pressing the enter key to start the Edit Grid dialog.  The cell can be selected either using the arrow 

keys or the mouse.  A single click will select the cell and a double click will start the Edit Grid dialog.  A 
double click on the Example name cell will select the whole row and a double click on the Input/Output 

name cell will select the whole column.  The row or the column can be deselected by pressing the Esc 
key. 

 
Creating a New Grid  

 

A new Grid is created by pressing the new toolbar button or using the File > New  menu command.  
The new Grid will be empty except for a horizontal line, a vertical line and an underline marker that 

shows the current position in the Grid .  New Grid rows and columns are created at the current position.  
 

Creating the first Example row and Input/Output column  

 
Press return and a prompt will appear that says "Create new Example row?".  Answer Yes.  Another 

prompt will appear that says "Create new Input/Output column?".  An swer Yes again.  You will now see 
that the Grid has one cell containing "?", a row name containing "T:0" and a column name containing 

"I:0".  The "?" indicates that the cell has no value, the "T:0" indicates that it is a Training Example in row 

0 and the " I:0" indicates that is is an Input in column 0.  Press return again and an Edit Grid dialog box 
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will appear that allows you to enter the cell value.  Using the same dialog you can change the 

Input/Output column name, mode and type.  The dialog can also be used to change the Example row 
name and type.   

 
Creating more Input/Output columns.  

 

Move the marker one cell to the right by pressing the right arrow or tab key.  Now press the return key 
and a prompt will appear that says "Create new Input/Output column ?".  Answer Yes.  Press return 

again and the Edit Grid dialog box will appear.  This time the Example row will already contain a name 
and type.  You can set the cell value, the Input/Output name and the type can be set to "I:" for input, 

"O:" for output, " X:" for exclude or "S:" for serial.  The mode can be set to "Real", "Integer", "Bool" 
"Text" or "Image".  Any type of Input/Output column can be inserted into the Grid using the functions on 

the Insert menu. 

 
Creating more Example rows.  

 
Move the marker one cell down by pressing the down arrow key.  Now press the return key and a 

prompt will appear that says "Create new Example row?".  Answer Yes.  Press return again and the 

Edit Grid dialog box will appear.  This time the Input/Output column will already c ontain a name and 
type.  You can set the cell value, Example name and the type can be set to T:  for training, V:  for 

validating, Q: for querying or X:  for exclude.  Any type of Example row be inserted into the Grid using 
the functions on the Insert menu. 

 
Copying Example rows and Input/Output columns.  

 

Double click on the name to select the whole row or column.  Cut  will remove the selected row or 
column and place it on the clipboard.  Copy will place a copy of the selected row or column on the 

clipboard.  Paste  will insert a copy of the clipboard before the currently selected row or column.  If 
the clipboard contains a row then Paste will insert the row into the Grid .  If the clipboard contains a 

column then Paste  will insert a column into the Grid .  The invisible Grid data, limits and defaulted 

values, will be regenerated after a Paste  column thus any neural network that has already been 
generated from the Grid will be invalidated. 

 

 Row names  

  
Example row names can be entered or produced automatically.  The row types can use different colors. 

 

 Column names  

  
Input/Output column names can  be entered or produced automatically.  The column types can use 
different colors.  

 

 Grid cells  
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Grid cells can contain values in real, integer, bool, text or image format.  Any notes can be added to grid 

cells. Special key notes are used to trigger diagnostic dumps in the trace file. 
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Network 

  

 

The Network  view shows how the nodes in an EasyNN -plus  neural network are interconnected.  

When this view is opened the Network Editor  starts.  Any source node can be selected with the left 
mouse button and any destination node can be selected with right mouse button.  The network nodes 

and connections can be edited to produce any configuration. 
 

How to create a new neural network  
 

A new neural network can be created from the  Grid  by pressing the New Network  toolbar button or 

selecting Action > New Network .  This will produce the New Network dialog.  This dialog allows the 
neural network configuration to be specified.  The dialog will alr eady contain the necessary information 

to generate a neural network that will be capable of learning the information in the Grid.  However, the 
generated network may take a long time to learn and it may give poor results when tested.  A better 

neural network can be generated by checking Grow hidden layer 1 and allowing EasyNN -plus  to 

determine the optimum number of nodes and connections.   
 

It is rarely necessary to have more than one layer of hidden nodes but EasyNN -plus  will generate two 
or three hidden l ayers if Grow hidden layer 2 and Grow hidden layer 3 are checked.   

 

The time that EasyNN -plus  will spend looking for the optimum network can be controlled by setting the 
Growth rate variables.  Every time that the period expires EasyNN -plus  will generate a new neural 

network slightly different from the previous one.  The best network is saved.  
 

How to use the Network editor  
 

To create a network manually using the Network Editor start with a suitable Grid and then use New 
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Network but do not check Connect layers.  This will create the optimum number of nodes but the 

weights between the layers will not be connected.  
 

To connect and disconnect nodes the source and the destination of the weight connections need to be 
selected.  This is done using the mouse.  The left button selects the source and the right button selects 

the destination.  First left click on a node to select the source and then right click on a node to select the 

destination.  The selected source node will now have a wide red border.  The other nodes in the source 
layer will have a narrow red border.  The destination node will now have a wide blue border.  The other 

nodes in the destination layer will have a narrow blue border.  The right click will also open a menu of 
functions that are used to change the network connections or add and delete nodes. 

 
Any nodes or layers can be connected to any other nodes or layers.  Feed forward, feedback and skip 

layer connections are possible.  

 
The number of hidden layer nodes can be increased or decreased and hidden layers can be added if 

needed.  The nodes will be reconnected using the connections that are held in the slave memory.  
These connections will be as close as possible to its previous state.  It can then be edited further as 

required. 

 
 

 Input Node  

  
Input nodes are connected to the input columns in the grid.  
 

 Hidden Node  

  
Hidden nodes are fully connected to input nodes, output nodes or other layers of hidden nodes.  
 

 Output Node  

  
Output nodes are connected to the output columns in the grid.  

 

 Connections  

  
The connections between the nodes are weighted.  The color represents the polarity and the thickness 

represents the weight value.  The weight values and polarity change as the network learns.  
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 Edit menu  

  
Network Editor  menu.  Nodes and layers can be connected and disconnected.  Hidden layers can be 
added, increased or decreased. 
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Learning Progress 

  

 

The Learning Progress  view shows how learning is progressing.  Up to 5000 graph points are 

recorded.  This is sufficient for over 200,000,000 learning cycles.  The graph is produced by sampling 
these points.  The horizontal axis is nonlinear to allow the whole learning progress to be displayed.  As 

more cycles are executed the graph is squashed to the left.  The scaled errors for all example rows are 

used.  The red line is the maximum example error, the blue line is the  minimum example error and the 
green line is the average example error.  The orange line is the average validating error.  The errors are 

also shown on the Example errors view . 
 

 Learning progress  
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The learning progress graph shows the maximum, average and minimum training error.  The average 
validating error is shown if any validating examples rows are included.  The graph is squashed to the left 

as learning progresses so that the whole learning curve is visible.  Up to 200,000,000 learning cycles can 
be displayed on the graph. 

 

 Vertical scale  

  
The default vertical scale is 0.0000 to 1.0000 but  can be adjusted by clicking on the vertical scaling and 
zoom toolbar icons.  Details of the curve can be seen by scaling and zooming the graph.  

 

 Horizontal scale  

  
The horizontal scale is renumbered as learning progresses by packing to the left.  The entire learning 

curve is visible. 
 

 Network  
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The current counts of nodes and connection weights in the neural ne twork.  This is updated if the 
network is reconfigured automatically or manually.  

 

 Diagnostic Array data  

  
A copy of the data in the  Diagnostic Array .  The values are updated while learning progresses.  

 
 

 Learning and validating  

  
The target error, learning and validating progress details.  The validating and scoring results are shown 

when the number of validating examples is greater t han 0. 
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Predictions 

  

 

The Predictions view has two boxes that show how close the predicted value for each example output is 

to the true value.  The training and validating examples are shown in se parate boxes.  The position of 
the values on both axis are scaled to be from a minimum of 0 to a maximum of 1.  Predicted outputs for 

training examples get closer to the true values as training progresses.  If the predicted values are very 

close to the true values then the dots will be on the diagonal line.  If most of the dots are close to the 
diagonal line the network may be over -trained and it may not generalize well.  


